AMD Investigates USB Flakiness With PCIe 4 And 500 Series Chipsets, Here Are Possible Fixes

0
29
AMD Ryzen 500 chipsets PCIe 4 USB Bugs


There have been some rumblings in recent months about USB connectivity problems with AMD Ryzen processors in combination with 500 series chipset-based motherboards. To be more specific, the problem seems to stem from USB 2.0 ports that act erratically when PCIe 4.0 is enabled on the motherboard and a PCIe 4-enabled device is installed — like a GPU, for example. Given that many enthusiasts are rocking new GPUs like the Radeon RX 6800 or GeForce RTX 30 Series, which are PCIe 4.0-enabled, this can certainly be a problem.

Users are experiencing problems where low-speed devices like mice, keyboards, and headsets are dropping out periodically, without any rhyme or reason, when attached to a USB 2.0 port. The problem seems to manifest itself the most under high CPU loads. Switching the accessories from a USB 2.0 port to a free USB 3.0 port seems to alleviate the problem for many.

However, this is not a workable solution for some people, and they are fed up with the USB 2.0 dropouts. There are a couple of reddit threads making the rounds now discussing the matter, with the most recent one garnering over 1,100 comments. 

gigabyte motherboard

“My USB headset will crackle or just drop out, my mouse will stop responding for a bit, etc.,” wrote Reonu_, who started the most recent reddit discussion thread. “Having a PCIe 4 GPU simply breaks USB and it happens on both Zen 2 and Zen 3. Yet it hasn’t even been acknowledged by AMD.”

“After installing my new graphic card 3090 I had loads of USB disconnects,” added redditor gibbo77. “I spent a lot of time trying to diagnose problem as I changed my power supply as well. A few days later I found a few posts saying that PCIe 4.0 was to blame, after changing to PCIe 3.0 I have not had any problems since.”

The thread is an interesting read, with many users fighting back and forth over what the true solution is, and some chiming in that they aren’t having any problems whatsoever with USB 2.0 disconnects on 500 Series motherboards. However, we reached out to AMD directly to see if they’ve been keeping track of the user complaints, and they provided the following response:

AMD is aware of reports that some users are experiencing intermittent USB connectivity issues reported on 500 Series chipsets. We have been analyzing the root cause and are reaching out to affected users to gather detailed hardware configurations, steps to reproduce the issue, specific logs, and other system information pertinent to verifying our development efforts. We will provide an update when we have more details to share.

Since that response doesn’t give really give us any immediate guidance as to what to do for now, here’s are some remedies that you might want to try if you’re currently experiencing USB 2.0 disconnect issues:

  1. Set PCIe to Gen 3 in the BIOS
  2. Update to the latest BIOS with newest AGESA available for your motherboard
  3. Install the latest AMD chipset drivers (available here)
  4. After installing latest chipset drivers and running Windows Update, some users have reported manually removing / uninstalling USB ports and root hubs in Device Manger, re-booting, and letting the ports get redetected has helped.

Let us know in the comments section below if you’ve been experiencing similar issues with your AMD rig. And we’ll keep you up-to-date when AMD comes back with a solution to the USB 2.0 disconnect woes.



Source link

Leave a Reply